Ubuntu 5.04 : courier vulnerability (USN-174-1)

Medium Nessus Plugin ID 20584

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

A Denial of Service vulnerability has been discovered in the Courier mail server. Due to a flawed status code check, failed DNS (domain name service) queries for SPF (sender policy framework) were not handled properly and could lead to memory corruption. A malicious DNS server could exploit this to crash the Courier server.

However, SPF is not enabled by default, so you are only vulnerable if you explicitly enabled it.

The Ubuntu 4.10 version of courier is not affected by this.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

Plugin Details

Severity: Medium

ID: 20584

File Name: ubuntu_USN-174-1.nasl

Version: 1.14

Type: local

Agent: unix

Published: 2006/01/15

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:courier-authdaemon, p-cpe:/a:canonical:ubuntu_linux:courier-authmysql, p-cpe:/a:canonical:ubuntu_linux:courier-authpostgresql, p-cpe:/a:canonical:ubuntu_linux:courier-base, p-cpe:/a:canonical:ubuntu_linux:courier-doc, p-cpe:/a:canonical:ubuntu_linux:courier-faxmail, p-cpe:/a:canonical:ubuntu_linux:courier-imap, p-cpe:/a:canonical:ubuntu_linux:courier-imap-ssl, p-cpe:/a:canonical:ubuntu_linux:courier-ldap, p-cpe:/a:canonical:ubuntu_linux:courier-maildrop, p-cpe:/a:canonical:ubuntu_linux:courier-mlm, p-cpe:/a:canonical:ubuntu_linux:courier-mta, p-cpe:/a:canonical:ubuntu_linux:courier-mta-ssl, p-cpe:/a:canonical:ubuntu_linux:courier-pcp, p-cpe:/a:canonical:ubuntu_linux:courier-pop, p-cpe:/a:canonical:ubuntu_linux:courier-pop-ssl, p-cpe:/a:canonical:ubuntu_linux:courier-ssl, p-cpe:/a:canonical:ubuntu_linux:courier-webadmin, p-cpe:/a:canonical:ubuntu_linux:sqwebmail, cpe:/o:canonical:ubuntu_linux:5.04

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2005/08/26

Reference Information

CVE: CVE-2005-2151

USN: 174-1