Ubuntu 4.10 / 5.04 : python2.1, python2.2, python2.3, gnumeric vulnerabilities (USN-173-4)

high Nessus Plugin ID 20583
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

USN-173-1 fixed a buffer overflow vulnerability in the PCRE library.
However, it was found that the various python packages and gnumeric contain static copies of the library code, so these packages need to be updated as well.

In gnumeric this bug could be exploited to execute arbitrary code with the privileges of the user if the user was tricked into opening a specially crafted spreadsheet document.

In python, the impact depends on the particular application that uses python's 're' (regular expression) module. In python server applications that process unchecked arbitrary regular expressions with the 're' module, this could potentially be exploited to remotely execute arbitrary code with the privileges of the server.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

Plugin Details

Severity: High

ID: 20583

File Name: ubuntu_USN-173-4.nasl

Version: 1.15

Type: local

Agent: unix

Published: 1/15/2006

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.5

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:gnumeric, p-cpe:/a:canonical:ubuntu_linux:gnumeric-common, p-cpe:/a:canonical:ubuntu_linux:gnumeric-doc, p-cpe:/a:canonical:ubuntu_linux:gnumeric-plugins-extra, p-cpe:/a:canonical:ubuntu_linux:idle-python2.1, p-cpe:/a:canonical:ubuntu_linux:idle-python2.2, p-cpe:/a:canonical:ubuntu_linux:idle-python2.3, p-cpe:/a:canonical:ubuntu_linux:python2.1, p-cpe:/a:canonical:ubuntu_linux:python2.1-dev, p-cpe:/a:canonical:ubuntu_linux:python2.1-doc, p-cpe:/a:canonical:ubuntu_linux:python2.1-examples, p-cpe:/a:canonical:ubuntu_linux:python2.1-gdbm, p-cpe:/a:canonical:ubuntu_linux:python2.1-mpz, p-cpe:/a:canonical:ubuntu_linux:python2.1-tk, p-cpe:/a:canonical:ubuntu_linux:python2.1-xmlbase, p-cpe:/a:canonical:ubuntu_linux:python2.2, p-cpe:/a:canonical:ubuntu_linux:python2.2-dev, p-cpe:/a:canonical:ubuntu_linux:python2.2-doc, p-cpe:/a:canonical:ubuntu_linux:python2.2-examples, p-cpe:/a:canonical:ubuntu_linux:python2.2-gdbm, p-cpe:/a:canonical:ubuntu_linux:python2.2-mpz, p-cpe:/a:canonical:ubuntu_linux:python2.2-tk, p-cpe:/a:canonical:ubuntu_linux:python2.2-xmlbase, p-cpe:/a:canonical:ubuntu_linux:python2.3, p-cpe:/a:canonical:ubuntu_linux:python2.3-dev, p-cpe:/a:canonical:ubuntu_linux:python2.3-doc, p-cpe:/a:canonical:ubuntu_linux:python2.3-examples, p-cpe:/a:canonical:ubuntu_linux:python2.3-gdbm, p-cpe:/a:canonical:ubuntu_linux:python2.3-mpz, p-cpe:/a:canonical:ubuntu_linux:python2.3-tk, cpe:/o:canonical:ubuntu_linux:4.10, cpe:/o:canonical:ubuntu_linux:5.04

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 8/31/2005

Reference Information

CVE: CVE-2005-2491

BID: 14620

USN: 173-4