Ubuntu 4.10 / 5.04 : pcre3, apache2 vulnerabilities (USN-173-2)

high Nessus Plugin ID 20581
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

USN-173-1 fixed a buffer overflow vulnerability in the PCRE library.
However, it was determined that this did not suffice to prevent all possible overflows, so another update is necessary.

In addition, it was found that the Ubuntu 4.10 version of Apache 2 contains a static copy of the library code, so this package needs to be updated as well. In Ubuntu 5.04, Apache 2 uses the external library from the libpcre3 package.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

Plugin Details

Severity: High

ID: 20581

File Name: ubuntu_USN-173-2.nasl

Version: 1.15

Type: local

Agent: unix

Published: 1/15/2006

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.5

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:apache2, p-cpe:/a:canonical:ubuntu_linux:apache2-common, p-cpe:/a:canonical:ubuntu_linux:apache2-doc, p-cpe:/a:canonical:ubuntu_linux:apache2-mpm-perchild, p-cpe:/a:canonical:ubuntu_linux:apache2-mpm-prefork, p-cpe:/a:canonical:ubuntu_linux:apache2-mpm-threadpool, p-cpe:/a:canonical:ubuntu_linux:apache2-mpm-worker, p-cpe:/a:canonical:ubuntu_linux:apache2-prefork-dev, p-cpe:/a:canonical:ubuntu_linux:apache2-threaded-dev, p-cpe:/a:canonical:ubuntu_linux:libapr0, p-cpe:/a:canonical:ubuntu_linux:libapr0-dev, p-cpe:/a:canonical:ubuntu_linux:libpcre3, p-cpe:/a:canonical:ubuntu_linux:libpcre3-dev, p-cpe:/a:canonical:ubuntu_linux:pcregrep, p-cpe:/a:canonical:ubuntu_linux:pgrep, cpe:/o:canonical:ubuntu_linux:4.10, cpe:/o:canonical:ubuntu_linux:5.04

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 8/24/2005

Reference Information

CVE: CVE-2005-2491

BID: 14620

USN: 173-2