Mandrake Linux Security Advisory : apache2-mod_auth_pgsql (MDKSA-2006:009)

Critical Nessus Plugin ID 20475


The remote Mandrake Linux host is missing one or more security updates.


iDefense discovered several format string vulnerabilities in the way that mod_auth_pgsql logs information which could potentially be used by a remote attacker to execute arbitrary code as the apache user if mod_auth_pgsql is used for user authentication.

The provided packages have been patched to prevent this problem.


Update the affected apache-mod_auth_pgsql and / or apache2-mod_auth_pgsql packages.

Plugin Details

Severity: Critical

ID: 20475

File Name: mandrake_MDKSA-2006-009.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/01/15

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:apache-mod_auth_pgsql, p-cpe:/a:mandriva:linux:apache2-mod_auth_pgsql, cpe:/o:mandrakesoft:mandrake_linux:10.1, cpe:/o:mandriva:linux:2006, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2006/01/06

Reference Information

CVE: CVE-2005-3656

MDKSA: 2006:009