Mandrake Linux Security Advisory : ffmpeg (MDKSA-2005:231)

High Nessus Plugin ID 20462


The remote Mandrake Linux host is missing one or more security updates.


Simon Kilvington discovered a vulnerability in FFmpeg libavcodec, which can be exploited by malicious people to cause a DoS (Denial of Service) and potentially to compromise a user's system.

The vulnerability is caused due to a boundary error in the 'avcodec_default_get_buffer()' function of 'utils.c' in libavcodec.
This can be exploited to cause a heap-based buffer overflow when a specially crafted 1x1 '.png' file containing a palette is read.

The updated packages have been patched to prevent this problem.


Update the affected packages.

Plugin Details

Severity: High

ID: 20462

File Name: mandrake_MDKSA-2005-231.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/01/15

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ffmpeg, p-cpe:/a:mandriva:linux:lib64ffmpeg0, p-cpe:/a:mandriva:linux:lib64ffmpeg0-devel, p-cpe:/a:mandriva:linux:libffmpeg0, p-cpe:/a:mandriva:linux:libffmpeg0-devel, cpe:/o:mandriva:linux:2006

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/12/14

Reference Information

CVE: CVE-2005-4048

MDKSA: 2005:231