Mandrake Linux Security Advisory : binutils (MDKSA-2005:215)

Medium Nessus Plugin ID 20447


The remote Mandrake Linux host is missing one or more security updates.


Integer overflows in various applications in the binutils package may allow attackers to execute arbitrary code via a carefully crafted object file.

The updated packages have been patched to help address these problems.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 20447

File Name: mandrake_MDKSA-2005-215.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2006/01/15

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:binutils, p-cpe:/a:mandriva:linux:lib64binutils2, p-cpe:/a:mandriva:linux:lib64binutils2-devel, p-cpe:/a:mandriva:linux:libbinutils2, p-cpe:/a:mandriva:linux:libbinutils2-devel, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/11/23

Reference Information

CVE: CVE-2005-1704

MDKSA: 2005:215