Mandrake Linux Security Advisory : xli (MDKSA-2005:192)

Medium Nessus Plugin ID 20434


The remote Mandrake Linux host is missing a security update.


Ariel Berkman discovered several buffer overflows in xloadimage, which are also present in xli, a command line utility for viewing images in X11, and could be exploited via large image titles and cause the execution of arbitrary code.

The updated packages have been patched to address this issue.


Update the affected xli package.

Plugin Details

Severity: Medium

ID: 20434

File Name: mandrake_MDKSA-2005-192.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/01/15

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:xli, cpe:/o:mandriva:linux:2006, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/10/20

Reference Information

CVE: CVE-2005-3178

MDKSA: 2005:192