RHEL 2.1 : auth_ldap (RHSA-2006:0179)

High Nessus Plugin ID 20400


The remote Red Hat host is missing a security update.


An updated auth_ldap packages that fixes a format string security issue is now available for Red Hat Enterprise Linux 2.1.

This update has been rated as having critical security impact by the Red Hat Security Response Team.

The auth_ldap package is an httpd module that allows user authentication against information stored in an LDAP database.

A format string flaw was found in the way auth_ldap logs information.
It may be possible for a remote attacker to execute arbitrary code as the 'apache' user if auth_ldap is used for user authentication. The Common Vulnerabilities and Exposures project assigned the name CVE-2006-0150 to this issue.

Note that this issue only affects servers that have auth_ldap installed and configured to perform user authentication against an LDAP database.

All users of auth_ldap should upgrade to this updated package, which contains a backported patch to resolve this issue.

This issue does not affect the Red Hat Enterprise Linux 3 or 4 distributions as they do not include the auth_ldap package.


Update the affected auth_ldap package.

See Also



Plugin Details

Severity: High

ID: 20400

File Name: redhat-RHSA-2006-0179.nasl

Version: $Revision: 1.16 $

Type: local

Agent: unix

Published: 2006/01/11

Modified: 2016/12/29

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:auth_ldap, cpe:/o:redhat:enterprise_linux:2.1

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2006/01/10

Vulnerability Publication Date: 2006/01/09

Reference Information

CVE: CVE-2006-0150

OSVDB: 22301

RHSA: 2006:0179