Apache mod_ssl ssl_hook_Access Error Handling DoS

Medium Nessus Plugin ID 20386


The remote web server is affected by a denial of service vulnerability.


The version of Apache running on the remote host is affected by a denial of service vulnerability due to a flaw in mod_ssl that occurs when it is configured with an SSL vhost with access control and a custom 400 error page. A remote attacker can exploit this, via a non-SSL request to an SSL port, to cause a NULL pointer to be dereferenced, resulting in crashing individual child processes or even the entire server.


Upgrade to Apache version 2.0.58 or later. Alternatively, update the Apache configuration to use 'SSLRequire' whenever 'SSLCipherSuite' is used.

See Also



Plugin Details

Severity: Medium

ID: 20386

File Name: apache_mod_ssl_error_document_dos.nasl

Version: $Revision: 1.24 $

Type: remote

Family: Web Servers

Published: 2006/01/10

Modified: 2018/01/23

Dependencies: 48204

Risk Information

Risk Factor: Medium


Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.9

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/05/01

Vulnerability Publication Date: 2005/12/05

Reference Information

CVE: CVE-2005-3357

BID: 16152

OSVDB: 22261