RHEL 3 : perl (RHSA-2005:881)

medium Nessus Plugin ID 20367
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

Updated Perl packages that fix security issues and bugs are now available for Red Hat Enterprise Linux 3.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

Perl is a high-level programming language commonly used for system administration utilities and Web programming.

An integer overflow bug was found in Perl's format string processor.
It is possible for an attacker to cause perl to crash or execute arbitrary code if the attacker is able to process a malicious format string. This issue is only exploitable through a script wich passes arbitrary untrusted strings to the format string processor. The Common Vulnerabilities and Exposures project assigned the name CVE-2005-3962 to this issue.

Paul Szabo discovered a bug in the way Perl's File::Path::rmtree module removed directory trees. If a local user has write permissions to a subdirectory within the tree being removed by File::Path::rmtree, it is possible for them to create setuid binary files. (CVE-2005-0448)

Solar Designer discovered several temporary file bugs in various Perl modules. A local attacker could overwrite or create files as the user running a Perl script that uses a vulnerable module. (CVE-2004-0976)

Users of Perl are advised to upgrade to these updated packages, which contain backported patches to correct these issues as well as fixes for several bugs.

Solution

Update the affected packages.

See Also

https://access.redhat.com/security/cve/cve-2004-0976

https://access.redhat.com/security/cve/cve-2005-0448

https://access.redhat.com/security/cve/cve-2005-3962

https://access.redhat.com/errata/RHSA-2005:881

Plugin Details

Severity: Medium

ID: 20367

File Name: redhat-RHSA-2005-881.nasl

Version: 1.24

Type: local

Agent: unix

Published: 12/30/2005

Updated: 1/14/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.3

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.4

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:perl, p-cpe:/a:redhat:enterprise_linux:perl-CGI, p-cpe:/a:redhat:enterprise_linux:perl-CPAN, p-cpe:/a:redhat:enterprise_linux:perl-DB_File, p-cpe:/a:redhat:enterprise_linux:perl-suidperl, cpe:/o:redhat:enterprise_linux:3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 12/20/2005

Vulnerability Publication Date: 2/9/2005

Reference Information

CVE: CVE-2004-0976, CVE-2005-0448, CVE-2005-3962

RHSA: 2005:881