RHEL 4 : gpdf (RHSA-2005:867)

High Nessus Plugin ID 20362


The remote Red Hat host is missing a security update.


An updated gpdf package that fixes several security issues is now available for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the Red Hat Security Response Team.

The gpdf package is a GNOME based viewer for Portable Document Format (PDF) files.

Several flaws were discovered in gpdf. An attacker could construct a carefully crafted PDF file that could cause gpdf to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, and CVE-2005-3193 to these issues.

Users of gpdf should upgrade to this updated package, which contains a backported patch to resolve these issues.


Update the affected gpdf package.

See Also






Plugin Details

Severity: High

ID: 20362

File Name: redhat-RHSA-2005-867.nasl

Version: $Revision: 1.17 $

Type: local

Agent: unix

Published: 2005/12/30

Modified: 2016/12/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:gpdf, cpe:/o:redhat:enterprise_linux:4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2005/12/20

Vulnerability Publication Date: 2005/12/05

Reference Information

CVE: CVE-2005-3191, CVE-2005-3192, CVE-2005-3193, CVE-2005-3628

BID: 15721, 15725, 15726, 15727

OSVDB: 21462, 21463

RHSA: 2005:867