GLSA-200512-16 : OpenMotif, AMD64 x86 emulation X libraries: Buffer overflows in libUil library

High Nessus Plugin ID 20357

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200512-16 (OpenMotif, AMD64 x86 emulation X libraries: Buffer overflows in libUil library)

xfocus discovered two potential buffer overflows in the libUil library, in the diag_issue_diagnostic and open_source_file functions.
Impact :

Remotely-accessible or SUID applications making use of the affected functions might be exploited to execute arbitrary code with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.

Solution

All OpenMotif users should upgrade to an unaffected version:
# emerge --sync # emerge --ask --oneshot --unmerge --verbose x11-libs/openmotif # emerge --ask --oneshot --verbose x11-libs/openmotif All AMD64 x86 emulation X libraries users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose app-emulation/emul-linux-x86-xlibs

See Also

http://www.nessus.org/u?62673d1c

https://security.gentoo.org/glsa/200512-16

Plugin Details

Severity: High

ID: 20357

File Name: gentoo_GLSA-200512-16.nasl

Version: 1.12

Type: local

Published: 2005/12/30

Updated: 2018/11/19

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:emul-linux-x86-xlibs, p-cpe:/a:gentoo:linux:openmotif, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list, Host/Gentoo/arch

Patch Publication Date: 2005/12/28

Reference Information

CVE: CVE-2005-3964

GLSA: 200512-16