GLSA-200512-04 : Openswan, IPsec-Tools: Vulnerabilities in ISAKMP Protocol implementation

High Nessus Plugin ID 20313


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200512-04 (Openswan, IPsec-Tools: Vulnerabilities in ISAKMP Protocol implementation)

The Oulu University Secure Programming Group (OUSPG) discovered that various ISAKMP implementations, including Openswan and racoon (included in the IPsec-Tools package), behave in an anomalous way when they receive and handle ISAKMP Phase 1 packets with invalid or abnormal contents.
Impact :

A remote attacker could craft specific packets that would result in a Denial of Service attack, if Openswan and racoon are used in specific, weak configurations.
Workaround :

There is no known workaround at this time.


All Openswan users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/openswan-2.4.4' All IPsec-Tools users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose net-firewall/ipsec-tools

See Also

Plugin Details

Severity: High

ID: 20313

File Name: gentoo_GLSA-200512-04.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2005/12/15

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ipsec-tools, p-cpe:/a:gentoo:linux:openswan, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/12/12

Reference Information

CVE: CVE-2005-3671, CVE-2005-3732

OSVDB: 60991, 61003

GLSA: 200512-04