Fedora Core 3 : gpdf-2.8.2-5.2 (2005-1125)

Medium Nessus Plugin ID 20277


The remote Fedora Core host is missing a security update.


Several flaws were discovered in Xpdf, which is used internally by gpdf. An attacker could construct a carefully crafted PDF file that could cause gpdf to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the name CVE-2005-3193 to these issues.

Users of gpdf should upgrade to this updated package, which contains a patch to resolve these issues.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected gpdf and / or gpdf-debuginfo packages.

See Also


Plugin Details

Severity: Medium

ID: 20277

File Name: fedora_2005-1125.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2005/12/08

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:gpdf, p-cpe:/a:fedoraproject:fedora:gpdf-debuginfo, cpe:/o:fedoraproject:fedora_core:3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2005/12/07

Reference Information

CVE: CVE-2005-3193

FEDORA: 2005-1125