GLSA-200511-23 : chmlib, KchmViewer: Stack-based buffer overflow

Medium Nessus Plugin ID 20267


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200511-23 (chmlib, KchmViewer: Stack-based buffer overflow)

Sven Tantau reported about a buffer overflow vulnerability in chmlib. The function '_chm_decompress_block()' does not properly perform boundary checking, resulting in a stack-based buffer overflow.
Impact :

By convincing a user to open a specially crafted ITSS or CHM file, using KchmViewer or a program makes use of chmlib, a remote attacker could execute arbitrary code with the privileges of the user running the software.
Workaround :

There is no known workaround at this time.


All chmlib users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/chmlib-0.37.4' All KchmViewer users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-text/kchmviewer-1.1'

See Also

Plugin Details

Severity: Medium

ID: 20267

File Name: gentoo_GLSA-200511-23.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/12/07

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:chmlib, p-cpe:/a:gentoo:linux:kchmviewer, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/11/28

Vulnerability Publication Date: 2005/09/12

Reference Information

CVE: CVE-2005-3318

OSVDB: 20335, 20974

GLSA: 200511-23