GLSA-200511-21 : Macromedia Flash Player: Remote arbitrary code execution

Medium Nessus Plugin ID 20265


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200511-21 (Macromedia Flash Player: Remote arbitrary code execution)

When handling a SWF file, the Macromedia Flash Player incorrectly validates the frame type identifier stored in the SWF file which is used as an index to reference an array of function pointers. A specially crafted SWF file can cause this index to reference memory outside of the scope of the Macromedia Flash Player, which in turn can cause the Macromedia Flash Player to use unintended memory address(es) as function pointers.
Impact :

An attacker serving a maliciously crafted SWF file could entice a user to view the SWF file and execute arbitrary code on the user's machine.
Workaround :

There is no known workaround at this time.


All Macromedia Flash Player users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-plugins/adobe-flash-7.0.61'

See Also

Plugin Details

Severity: Medium

ID: 20265

File Name: gentoo_GLSA-200511-21.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2005/12/07

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:adobe-flash, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/11/25

Vulnerability Publication Date: 2005/11/02

Reference Information

CVE: CVE-2005-2628

OSVDB: 18825

GLSA: 200511-21