GLSA-200511-18 : phpSysInfo: Multiple vulnerabilities

Medium Nessus Plugin ID 20262


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200511-18 (phpSysInfo: Multiple vulnerabilities)

Christopher Kunz from the Hardened-PHP Project discovered that phpSysInfo is vulnerable to local file inclusion, cross-site scripting and a HTTP Response Splitting attacks.
Impact :

A local attacker may exploit the file inclusion vulnerability by sending malicious requests, causing the execution of arbitrary code with the rights of the user running the web server. A remote attacker could exploit the vulnerability to disclose local file content.
Furthermore, the cross-site scripting issues gives a remote attacker the ability to inject and execute malicious script code in the user's browser context or to steal cookie-based authentication credentials.
The HTTP response splitting issue give an attacker the ability to perform site hijacking and cache poisoning.
Workaround :

There is no known workaround at this time.


All phpSysInfo users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/phpsysinfo-2.4.1'

See Also

Plugin Details

Severity: Medium

ID: 20262

File Name: gentoo_GLSA-200511-18.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2005/12/07

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:phpsysinfo, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/11/22

Vulnerability Publication Date: 2005/11/11

Reference Information

CVE: CVE-2005-3347, CVE-2005-3348

OSVDB: 20821, 21159

GLSA: 200511-18

CWE: 22, 352