CA Multiple Products Message Queuing Multiple Remote Vulnerabilities

Critical Nessus Plugin ID 20173


Arbitrary code can be executed on the remote host due to a flaw in the CAM service.


The remote version of CA Message Queuing Service contains a stack overflow in the 'log_security' function that may allow an attacker to execute arbitrary code on the remote host.

This version is also prone to denial of service on the TCP port 4105 as well as arbitrary code execution through spoofed CAFT packets.

An attacker does not need to be authenticated to exploit this flaw.


CA has released a set of patches for CAM 1.05, 1.07 and 1.11.

See Also

Plugin Details

Severity: Critical

ID: 20173

File Name: cacam_overflow.nasl

Version: $Revision: 1.18 $

Type: remote

Published: 2005/11/08

Modified: 2016/05/04

Dependencies: 20147

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

Required KB Items: CA/MessageQueuing

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2005/08/22

Vulnerability Publication Date: 2005/08/22

Exploitable With

Core Impact

Metasploit (CA CAM log_security() Stack Buffer Overflow (Win32))

Reference Information

CVE: CVE-2005-2667, CVE-2005-2668, CVE-2005-2669

BID: 14621, 14622, 14623

OSVDB: 18915, 18916, 18917