GLSA-200511-07 : OpenVPN: Multiple vulnerabilities

High Nessus Plugin ID 20157


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200511-07 (OpenVPN: Multiple vulnerabilities)

The OpenVPN client contains a format string bug in the handling of the foreign_option in options.c. Furthermore, when the OpenVPN server runs in TCP mode, it may dereference a NULL pointer under specific error conditions.
Impact :

A remote attacker could setup a malicious OpenVPN server and trick the user into connecting to it, potentially executing arbitrary code on the client's computer. A remote attacker could also exploit the NULL dereference issue by sending specific packets to an OpenVPN server running in TCP mode, resulting in a Denial of Service condition.
Workaround :

Do not use 'pull' or 'client' options in the OpenVPN client configuration file, and use UDP mode for the OpenVPN server.


All OpenVPN users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/openvpn-2.0.4'

See Also

Plugin Details

Severity: High

ID: 20157

File Name: gentoo_GLSA-200511-07.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2005/11/07

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openvpn, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/11/06

Vulnerability Publication Date: 2005/10/31

Reference Information

CVE: CVE-2005-3393, CVE-2005-3409

OSVDB: 20415, 20416

GLSA: 200511-07