GLSA-200511-05 : GNUMP3d: Directory traversal and XSS vulnerabilities

Medium Nessus Plugin ID 20155


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200511-05 (GNUMP3d: Directory traversal and XSS vulnerabilities)

Steve Kemp reported about two cross-site scripting attacks that are related to the handling of files (CVE-2005-3424, CVE-2005-3425). Also reported is a directory traversal vulnerability which comes from the attempt to sanitize input paths (CVE-2005-3123).
Impact :

A remote attacker could exploit this to disclose sensitive information or inject and execute malicious script code, potentially compromising the victim's browser.
Workaround :

There is no known workaround at this time.


All GNUMP3d users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-sound/gnump3d-2.9_pre7'

See Also

Plugin Details

Severity: Medium

ID: 20155

File Name: gentoo_GLSA-200511-05.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/11/07

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gnump3d, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/11/06

Vulnerability Publication Date: 2005/10/28

Reference Information

CVE: CVE-2005-3123, CVE-2005-3424, CVE-2005-3425

OSVDB: 20723

GLSA: 200511-05