QuickTime < 7.0.3 Multiple Vulnerabilities (Windows)

High Nessus Plugin ID 20136


The remote version of QuickTime may allow an attacker to execute arbitrary code on the remote host.


The remote Windows host is running a version of QuickTime that is older than QuickTime 7.0.3.

The remote version of this software is reportedly vulnerable to various buffer overflows that may allow an attacker to execute arbitrary code on the remote host by sending a malformed file to a victim and have him open it using QuickTime player.


Upgrade to QuickTime 7.0.3 or later.

See Also


Plugin Details

Severity: High

ID: 20136

File Name: quicktime_player_overflow2.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2005/11/04

Modified: 2011/04/13

Dependencies: 21561

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: SMB/QuickTime/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2005/11/03

Reference Information

CVE: CVE-2005-2753, CVE-2005-2754, CVE-2005-2755, CVE-2005-2756

BID: 15306, 15307, 15308, 15309

OSVDB: 20475, 20476, 20477, 20478