Quicktime < 7.0.3 Multiple Vulnerabilities (Mac OS X)

Medium Nessus Plugin ID 20135


The remote version of QuickTime may allow an attacker to execute arbitrary code on the remote host.


The remote Mac OS X host is running a version of Quicktime 7 which is older than Quicktime 7.0.3.

The remote version of this software is vulnerable to various buffer overflows which may allow an attacker to execute arbitrary code on the remote host by sending a malformed file to a victim and have him open it using QuickTime player.


Install Quicktime 7.0.3 or later.

See Also


Plugin Details

Severity: Medium

ID: 20135

File Name: macosx_Quicktime703.nasl

Version: $Revision: 1.17 $

Type: local

Agent: macosx

Published: 2005/11/04

Modified: 2016/11/28

Dependencies: 15573

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: MacOSX/QuickTime/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2005/11/02

Vulnerability Publication Date: 2005/11/03

Reference Information

CVE: CVE-2005-2753, CVE-2005-2754, CVE-2005-2755, CVE-2005-2756

BID: 15306, 15307, 15308, 15309

OSVDB: 20475, 20476, 20477, 20478