PHP < 4.4.1 / 5.0.6 Multiple Vulnerabilities

High Nessus Plugin ID 20111


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP installed on the remote host is older than 4.4.1 or 5.0.6. Such versions fail to protect the '$GLOBALS' superglobals variable from being overwritten due to weaknesses in the file upload handling code as well as the 'extract()' and 'import_request_variables()' functions. Depending on the nature of the PHP applications on the affected host, exploitation of this issue may lead to any number of attacks, including arbitrary code execution.

In addition, these versions may enable an attacker to exploit an integer overflow flaw in certain certain versions of the PCRE library, to enable PHP's 'register_globals' setting even if explicitly disabled in the configuration, and to launch cross-site scripting attacks involving PHP's 'phpinfo()' function.


Upgrade to PHP version 4.4.1 / 5.0.6 or later.

See Also

Plugin Details

Severity: High

ID: 20111

File Name: php_4_4_1.nasl

Version: 1.23

Type: remote

Family: CGI abuses

Published: 2005/11/01

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2005/08/20

Reference Information

CVE: CVE-2002-0229, CVE-2005-2491, CVE-2005-3388, CVE-2005-3389, CVE-2005-3390

BID: 14620, 15248, 15249, 15250

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990