Fedora Core 3 : gdb-6.1post-1.20040607.43.0.1 (2005-1032)

High Nessus Plugin ID 20100


The remote Fedora Core host is missing a security update.


This is an fc3 update for gdb regarding security issues :

CVE-2005-1704 Integer Overflow in gdb

This problem is that gdb's internal copy of bfd does not protect against heap-based overflow.

CVE-2005-1705 gdb arbitrary command execution

This problem allows unprotected .gdbinit files to execute arbitrary commands during gdb startup.

Fixes for both problems are found in :


Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected gdb and / or gdb-debuginfo packages.

See Also


Plugin Details

Severity: High

ID: 20100

File Name: fedora_2005-1032.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2005/10/28

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:gdb, p-cpe:/a:fedoraproject:fedora:gdb-debuginfo, cpe:/o:fedoraproject:fedora_core:3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2005/10/27

Reference Information

FEDORA: 2005-1032