Oracle Linux 8 : ruby:3.3 (ELSA-2024-3670)

medium Nessus Plugin ID 200309

Synopsis

The remote Oracle Linux host is missing one or more security updates.

Description

The remote Oracle Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2024-3670 advisory.

- Fix buffer overread vulnerability in StringIO.
(CVE-2024-27280) Resolves: RHEL-37448
- Fix RCE vulnerability with .rdoc_options in RDoc.
(CVE-2024-27281) Resolves: RHEL-37449
- Fix Arbitrary memory address read vulnerability with Regex search.
(CVE-2024-27282) Resolves: RHEL-37447

rubygem-abrt rubygem-mysql2

Tenable has extracted the preceding description block directly from the Oracle Linux security advisory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://linux.oracle.com/errata/ELSA-2024-3670.html

Plugin Details

Severity: Medium

ID: 200309

File Name: oraclelinux_ELSA-2024-3670.nasl

Version: 1.1

Type: local

Agent: unix

Published: 6/11/2024

Updated: 6/11/2024

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.0

CVSS v2

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 4.5

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:P/A:P

CVSS Score Source: CVE-2024-27282

CVSS v3

Risk Factor: Medium

Base Score: 6.6

Temporal Score: 5.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:rubygem-json, p-cpe:/a:oracle:linux:rubygems, p-cpe:/a:oracle:linux:rubygem-psych, cpe:/o:oracle:linux:8, p-cpe:/a:oracle:linux:rubygem-io-console, p-cpe:/a:oracle:linux:rubygem-pg, p-cpe:/a:oracle:linux:rubygem-typeprof, p-cpe:/a:oracle:linux:rubygem-bigdecimal, p-cpe:/a:oracle:linux:rubygem-racc, p-cpe:/a:oracle:linux:rubygem-rdoc, p-cpe:/a:oracle:linux:rubygem-irb, cpe:/a:oracle:linux:8::appstream, p-cpe:/a:oracle:linux:rubygem-power_assert, p-cpe:/a:oracle:linux:rubygems-devel, p-cpe:/a:oracle:linux:rubygem-bundler, p-cpe:/a:oracle:linux:rubygem-mysql2, p-cpe:/a:oracle:linux:rubygem-abrt-doc, p-cpe:/a:oracle:linux:rubygem-pg-doc, p-cpe:/a:oracle:linux:rubygem-rbs, p-cpe:/a:oracle:linux:rubygem-mysql2-doc, p-cpe:/a:oracle:linux:ruby-doc, p-cpe:/a:oracle:linux:rubygem-rexml, p-cpe:/a:oracle:linux:rubygem-abrt, cpe:/a:oracle:linux:8:10:appstream_base, p-cpe:/a:oracle:linux:ruby, p-cpe:/a:oracle:linux:rubygem-rake, p-cpe:/a:oracle:linux:ruby-bundled-gems, p-cpe:/a:oracle:linux:ruby-default-gems, p-cpe:/a:oracle:linux:rubygem-minitest, p-cpe:/a:oracle:linux:ruby-devel, p-cpe:/a:oracle:linux:ruby-libs, p-cpe:/a:oracle:linux:rubygem-test-unit, p-cpe:/a:oracle:linux:rubygem-rss

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/OracleLinux

Exploit Ease: No known exploits are available

Patch Publication Date: 6/7/2024

Vulnerability Publication Date: 4/23/2024

Reference Information

CVE: CVE-2024-27280, CVE-2024-27281, CVE-2024-27282

IAVA: 2024-A-0328