GLSA-200510-10 : uw-imap: Remote buffer overflow

High Nessus Plugin ID 20030


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200510-10 (uw-imap: Remote buffer overflow)

Improper bounds checking of user-supplied data while parsing IMAP mailbox names can lead to overflowing the stack buffer.
Impact :

Successful exploitation requires an authenticated IMAP user to request a malformed mailbox name. This can lead to execution of arbitrary code with the permissions of the IMAP server.
Workaround :

There are no known workarounds at this time.


All uw-imap users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-mail/uw-imap-2004g'

See Also

Plugin Details

Severity: High

ID: 20030

File Name: gentoo_GLSA-200510-10.nasl

Version: $Revision: 1.20 $

Type: local

Published: 2005/10/19

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:uw-imap, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2005/10/11

Vulnerability Publication Date: 2005/10/04

Reference Information

CVE: CVE-2005-2933

BID: 15009

OSVDB: 19856

GLSA: 200510-10