Oracle Linux 7 : edk2 (ELSA-2024-12408)

high Nessus Plugin ID 200100

Synopsis

The remote Oracle Linux host is missing one or more security updates.

Description

The remote Oracle Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2024-12408 advisory.

- Create new 1.7.0 release for OL7 which includes the following fixed CVEs:
{CVE-2023-45229} {CVE-2023-45230} {CVE-2023-45231} {CVE-2023-45232} {CVE-2023-45233} {CVE-2023-45234} {CVE-2023-45235} {CVE-2022-36763} {CVE-2022-36764} {CVE-2022-36765}
- Update to OpenSSL 3.0.10 which includes the following fixed CVEs:
{CVE-2023-2975} {CVE-2023-1255} {CVE-2023-0401} {CVE-2023-0217} {CVE-2023-0216} {CVE-2023-0215} {CVE-2022-4203} {CVE-2022-3996} {CVE-2022-3602} {CVE-2022-3786} {CVE-2022-3358} {CVE-2022-2274} {CVE-2022-1473} {CVE-2022-1434} {CVE-2022-1343} {CVE-2021-4044} {CVE-2021-23839}

* Tue Aug 22 2023 Aaron Young <[email protected]>
- Create new 1.6.6 release for OL7 which includes the following fixed CVEs:
{CVE-2019-14560}
- Update to OpenSSL 1.1.1v which includes the following fixed CVEs:
{CVE-2023-3817} {CVE-2023-3446} {CVE-2023-2650} {CVE-2023-0465} {CVE-2023-0466} {CVE-2023-0464} {CVE-2023-0286} {CVE-2023-0215} {CVE-2022-4450} {CVE-2022-4304} {CVE-2022-2097} {CVE-2022-2068} {CVE-2022-1292} {CVE-2022-0778} {CVE-2021-4160} {CVE-2021-3712} {CVE-2021-3711} {CVE-2021-3450} {CVE-2021-3449} {CVE-2021-23841} {CVE-2021-23840} {CVE-2020-1971} {CVE-2020-1967} {CVE-2019-1551} {CVE-2019-1563} {CVE-2019-1549} {CVE-2019-1547} {CVE-2019-1552} {CVE-2019-1543} {CVE-2018-0734} {CVE-2018-0735}

* Tue Jun 13 2023 Aaron Young <[email protected]>
- Create new 1.6.4.cvm release for OL7 which includes the following fixed CVEs:
{CVE-2021-38578}

* Tue Jun 28 2022 Aaron Young <[email protected]>
- Create new 1.6.0 release for OL7 which includes the following fixed CVEs:
{CVE-2022-0778}

* Tue Nov 23 2021 Aaron Young <[email protected]>
- Create new 1.5.0 release for OL7 which includes the following fixed CVEs:
{CVE-2021-23840} {CVE-2021-23841} {CVE-2021-38575}

* Thu Feb 18 2021 Aaron Young <[email protected]>
- Create new 1.4.0 release for OL7 which includes the following fixed CVEs:
{CVE-2019-14584} {CVE-2019-14562} {CVE-2019-11098} {CVE-2019-14559} {CVE-2019-14575} {CVE-2019-14559} {CVE-2019-14587} {CVE-2019-14558} {CVE-2019-14586} {CVE-2019-14563}

* Sat Oct 10 2020 Aaron Young <[email protected]>
- Create new 1.3 release for OL7 which includes the following fixed CVEs:
{CVE-2018-12182} {CVE-2019-13224} {CVE-2019-13225} {CVE-2019-14553}

* Fri May 17 2019 Aaron Young <[email protected]>

Tenable has extracted the preceding description block directly from the Oracle Linux security advisory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected AAVMF and / or OVMF packages.

See Also

https://linux.oracle.com/errata/ELSA-2024-12408.html

Plugin Details

Severity: High

ID: 200100

File Name: oraclelinux_ELSA-2024-12408.nasl

Version: 1.1

Type: local

Agent: unix

Published: 6/4/2024

Updated: 6/4/2024

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 8.3

Temporal Score: 6.5

Vector: CVSS2#AV:A/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-45235

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:oracle:linux:7, p-cpe:/a:oracle:linux:ovmf, cpe:/a:oracle:linux:7::kvm_utils, cpe:/a:oracle:linux:7::developer_kvm_utils, cpe:/a:oracle:linux:7::optional_latest, cpe:/a:oracle:linux:7:9:patch, p-cpe:/a:oracle:linux:aavmf, cpe:/a:oracle:linux:7::latest

Required KB Items: Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list, Host/local_checks_enabled

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/4/2024

Vulnerability Publication Date: 1/9/2024

Reference Information

CVE: CVE-2022-36763, CVE-2022-36764, CVE-2022-36765, CVE-2023-45229, CVE-2023-45230, CVE-2023-45231, CVE-2023-45232, CVE-2023-45233, CVE-2023-45234, CVE-2023-45235