MS05-047: Vulnerability in Plug and Play Could Allow Remote Code Execution and Local Elevation of Privilege (905749)

High Nessus Plugin ID 20000

Synopsis

A flaw in the Plug and Play service could allow an authenticated attacker to execute arbitrary code on the remote host and therefore elevate his privileges.

Description

The remote host contains a version of the Plug and Play service that contains a vulnerability in the way it handles user-supplied data.

An authenticated attacker could exploit this flaw by sending a malformed RPC request to the remote service and execute code within the SYSTEM context.

Solution

Microsoft has released a set of patches for Windows 2000 and XP.

See Also

https://docs.microsoft.com/en-us/security-updates/SecurityBulletins/2005/ms05-047

Plugin Details

Severity: High

ID: 20000

File Name: smb_nt_ms05-047.nasl

Version: 1.37

Type: local

Agent: windows

Published: 2005/10/11

Updated: 2018/11/15

Dependencies: 57033, 13855

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2005/10/11

Vulnerability Publication Date: 2005/10/11

Exploitable With

Core Impact

Reference Information

CVE: CVE-2005-2120

BID: 15065

MSFT: MS05-047

CERT: 214572

EDB-ID: 1271

MSKB: 905749