GLSA-200510-08 : xine-lib: Format string vulnerability

High Nessus Plugin ID 19978


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200510-08 (xine-lib: Format string vulnerability)

Ulf Harnhammar discovered a format string bug in the routines handling CDDB server response contents.
Impact :

An attacker could submit malicious information about an audio CD to a public CDDB server (or impersonate a public CDDB server). When the victim plays this CD on a multimedia frontend relying on xine-lib, it could end up executing arbitrary code.
Workaround :

There is no known workaround at this time.


All xine-lib users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose media-libs/xine-lib

See Also

Plugin Details

Severity: High

ID: 19978

File Name: gentoo_GLSA-200510-08.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/10/11

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:xine-lib, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/10/08

Vulnerability Publication Date: 2005/10/08

Reference Information

CVE: CVE-2005-2967

OSVDB: 19892

GLSA: 200510-08