Debian DSA-862-1 : ruby1.6 - programming error

High Nessus Plugin ID 19970

Synopsis

The remote Debian host is missing a security-related update.

Description

Yutaka Oiwa discovered a bug in Ruby, the interpreter for the object-oriented scripting language, that can cause illegal program code to bypass the safe level and taint flag protections check and be executed. The following matrix lists the fixed versions in our distributions :

old stable (woody) stable (sarge) unstable (sid) ruby 1.6.7-3woody5 n/a n/a ruby1.6 n/a 1.6.8-12sarge1 1.6.8-13 ruby1.8 n/a 1.8.2-7sarge2 1.8.3-1

Solution

Upgrade the ruby packages.

See Also

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=332742

http://www.debian.org/security/2005/dsa-862

Plugin Details

Severity: High

ID: 19970

File Name: debian_DSA-862.nasl

Version: 1.16

Type: local

Agent: unix

Published: 2005/10/11

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ruby1.8, cpe:/o:debian:debian_linux:3.1

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2005/10/11

Reference Information

CVE: CVE-2005-2337

CERT: 160012

DSA: 862