Mandrake Linux Security Advisory : clamav (MDKSA-2005:166)

High Nessus Plugin ID 19921


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability was discovered in ClamAV versions prior to 0.87. A buffer overflow could occure when processing malformed UPX-packed executables. As well, it could be sent into an infinite loop when processing specially crafted FSG-packed executables.

ClamAV version 0.87 is provided with this update which isn't vulnerable to these issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 19921

File Name: mandrake_MDKSA-2005-166.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2005/10/05

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:clamav, p-cpe:/a:mandriva:linux:clamav-db, p-cpe:/a:mandriva:linux:clamav-milter, p-cpe:/a:mandriva:linux:clamd, p-cpe:/a:mandriva:linux:lib64clamav1, p-cpe:/a:mandriva:linux:lib64clamav1-devel, p-cpe:/a:mandriva:linux:libclamav1, p-cpe:/a:mandriva:linux:libclamav1-devel, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/09/20

Reference Information

CVE: CVE-2005-2919, CVE-2005-2920

MDKSA: 2005:166