Mandrake Linux Security Advisory : cups (MDKSA-2005:165)

High Nessus Plugin ID 19920


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability in CUPS would treat a Location directive in cupsd.conf as case-sensitive, allowing attackers to bypass intended ACLs via a printer name containing uppercase or lowecase letters that are different from that which was specified in the Location directive.
This issue only affects versions of CUPS prior to 1.1.21rc1.

The updated packages have been patched to correct this problem.


Update the affected packages.

Plugin Details

Severity: High

ID: 19920

File Name: mandrake_MDKSA-2005-165.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/10/05

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:cups, p-cpe:/a:mandriva:linux:cups-common, p-cpe:/a:mandriva:linux:cups-serial, p-cpe:/a:mandriva:linux:lib64cups2, p-cpe:/a:mandriva:linux:lib64cups2-devel, p-cpe:/a:mandriva:linux:libcups2, p-cpe:/a:mandriva:linux:libcups2-devel, cpe:/o:mandrakesoft:mandrake_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/09/19

Reference Information

CVE: CVE-2004-2154

MDKSA: 2005:165