Mandrake Linux Security Advisory : python (MDKSA-2005:154)

High Nessus Plugin ID 19910


The remote Mandrake Linux host is missing one or more security updates.


Integer overflow in pcre_compile.c in Perl Compatible Regular Expressions (PCRE) before 6.2, as used in multiple products, allows attackers to execute arbitrary code via quantifier values in regular expressions, which leads to a heap-based buffer overflow.

The python packages use a private copy of pcre code.

The updated packages have been patched to correct this problem.


Update the affected packages.

Plugin Details

Severity: High

ID: 19910

File Name: mandrake_MDKSA-2005-154.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2005/10/05

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64python2.3, p-cpe:/a:mandriva:linux:lib64python2.3-devel, p-cpe:/a:mandriva:linux:libpython2.3, p-cpe:/a:mandriva:linux:libpython2.3-devel, p-cpe:/a:mandriva:linux:python, p-cpe:/a:mandriva:linux:python-base, p-cpe:/a:mandriva:linux:python-docs, p-cpe:/a:mandriva:linux:tkinter, p-cpe:/a:mandriva:linux:xchat-python, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/08/26

Reference Information

CVE: CVE-2005-2491

MDKSA: 2005:154