Mandrake Linux Security Advisory : vim (MDKSA-2005:148)

High Nessus Plugin ID 19904


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability was discovered in the way that vim processed modelines. If a user with modelines enabled opened a textfile with a specially crafted modeline, arbitrary commands could be executed.


Update the affected packages.

Plugin Details

Severity: High

ID: 19904

File Name: mandrake_MDKSA-2005-148.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2005/10/05

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:vim-X11, p-cpe:/a:mandriva:linux:vim-common, p-cpe:/a:mandriva:linux:vim-enhanced, p-cpe:/a:mandriva:linux:vim-minimal, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/08/22

Reference Information

CVE: CVE-2005-2368

MDKSA: 2005:148