Mandrake Linux Security Advisory : proftpd (MDKSA-2005:140)

Medium Nessus Plugin ID 19897


The remote Mandrake Linux host is missing one or more security updates.


Two format string vulnerabilities were discovered in ProFTPD. The first exists when displaying a shutdown message containin the name of the current directory. This could be exploited by a user who creates a directory containing format specifiers and sets the directory as the current directory when the shutdown message is being sent.

The second exists when displaying response messages to the cleint using information retreived from a database using mod_sql. Note that mod_sql support is not enabled by default, but the contrib source file has been patched regardless.

The updated packages have been patched to correct these problems.


Update the affected proftpd and / or proftpd-anonymous packages.

See Also

Plugin Details

Severity: Medium

ID: 19897

File Name: mandrake_MDKSA-2005-140.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/10/05

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:proftpd, p-cpe:/a:mandriva:linux:proftpd-anonymous, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/08/15

Reference Information

CVE: CVE-2005-2390

MDKSA: 2005:140