Mandrake Linux Security Advisory : ethereal (MDKSA-2005:131)

High Nessus Plugin ID 19891


The remote Mandrake Linux host is missing one or more security updates.


A number of vulnerabilities were discovered in versions of Ethereal prior to version 0.10.12, including :

The SMB dissector could overflow a buffer or exhaust memory (CVE-2005-2365).

iDefense discovered that several dissectors are vulnerable to format string overflows (CVE-2005-2367).

A number of other portential crash issues in various dissectors have also been corrected.

This update provides Ethereal 0.10.12 which is not vulnerable to these issues.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 19891

File Name: mandrake_MDKSA-2005-131.nasl

Version: $Revision: 1.19 $

Type: local

Published: 2005/10/05

Modified: 2015/03/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ethereal, p-cpe:/a:mandriva:linux:ethereal-tools, p-cpe:/a:mandriva:linux:lib64ethereal0, p-cpe:/a:mandriva:linux:libethereal0, p-cpe:/a:mandriva:linux:tethereal, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2005/08/04

Reference Information

CVE: CVE-2005-2360, CVE-2005-2361, CVE-2005-2362, CVE-2005-2363, CVE-2005-2364, CVE-2005-2365, CVE-2005-2366, CVE-2005-2367

BID: 14399

MDKSA: 2005:131