GLSA-200509-18 : Qt: Buffer overflow in the included zlib library

High Nessus Plugin ID 19817


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200509-18 (Qt: Buffer overflow in the included zlib library)

Qt links to a bundled vulnerable version of zlib when emerged with the zlib USE-flag disabled. This may lead to a buffer overflow.
Impact :

By creating a specially crafted compressed data stream, attackers can overwrite data structures for applications that use Qt, resulting in a Denial of Service or potentially arbitrary code execution.
Workaround :

Emerge Qt with the zlib USE-flag enabled.


All Qt users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/qt-3.3.4-r8'

See Also

Plugin Details

Severity: High

ID: 19817

File Name: gentoo_GLSA-200509-18.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/10/05

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:qt, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/09/26

Vulnerability Publication Date: 2005/07/07

Reference Information

CVE: CVE-2005-1849, CVE-2005-2096

OSVDB: 17827, 18141

GLSA: 200509-18