Debian DSA-835-1 : cfengine - insecure temporary files

low Nessus Plugin ID 19804

Synopsis

The remote Debian host is missing a security-related update.

Description

Javier Fernandez-Sanguino Pena discovered several insecure temporary file uses in cfengine, a tool for configuring and maintaining networked machines, that can be exploited by a symlink attack to overwrite arbitrary files owned by the user executing cfengine, which is probably root.

Solution

Upgrade the cfengine package.

For the old stable distribution (woody) these problems have been fixed in version 1.6.3-9woody1.

For the stable distribution (sarge) these problems have been fixed in version 1.6.5-1sarge1.

See Also

http://www.debian.org/security/2005/dsa-835

Plugin Details

Severity: Low

ID: 19804

File Name: debian_DSA-835.nasl

Version: 1.20

Type: local

Agent: unix

Published: 10/5/2005

Updated: 1/4/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.7

CVSS v2

Risk Factor: Low

Base Score: 2.1

Vector: AV:L/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:cfengine, cpe:/o:debian:debian_linux:3.0, cpe:/o:debian:debian_linux:3.1

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 10/1/2005

Vulnerability Publication Date: 10/1/2005

Reference Information

CVE: CVE-2005-2960, CVE-2005-3137

DSA: 835