Oracle Linux 8 : xorg-x11-server (ELSA-2024-2995)

high Nessus Plugin ID 197995

Synopsis

The remote Oracle Linux host is missing one or more security updates.

Description

The remote Oracle Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2024-2995 advisory.

[1.20.4-24]
- Fix use after free related to CVE-2024-21886

[1.20.11-21]
- CVE fix for: CVE-2023-6816, CVE-2024-0229, CVE-2024-21885, CVE-2024-21886, CVE-2024-0408 and CVE-2024-0409 Resolves: https://issues.redhat.com/browse/RHEL-21207 Resolves: https://issues.redhat.com/browse/RHEL-20528 Resolves: https://issues.redhat.com/browse/RHEL-20378 Resolves: https://issues.redhat.com/browse/RHEL-20384 Resolves: https://issues.redhat.com/browse/RHEL-21191 Resolves: https://issues.redhat.com/browse/RHEL-21198

[1.20.11-20]
- CVE fix for: CVE-2023-6377, CVE-2023-6478 Resolves: https://issues.redhat.com/browse/RHEL-18321 Resolves: https://issues.redhat.com/browse/RHEL-18327

[1.20.11-19]
- CVE fix for: CVE-2023-5380 Resolves: https://issues.redhat.com/browse/RHEL-14060

[1.20.11-18]
- CVE fix for: CVE-2023-5367 Resolves: https://issues.redhat.com/browse/RHEL-13430

Tenable has extracted the preceding description block directly from the Oracle Linux security advisory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://linux.oracle.com/errata/ELSA-2024-2995.html

Plugin Details

Severity: High

ID: 197995

File Name: oraclelinux_ELSA-2024-2995.nasl

Version: 1.1

Type: local

Agent: unix

Published: 5/28/2024

Updated: 5/28/2024

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2023-6478

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS Score Source: CVE-2024-0409

Vulnerability Information

CPE: cpe:/a:oracle:linux:8:10:appstream_base, p-cpe:/a:oracle:linux:xorg-x11-server-xvfb, cpe:/a:oracle:linux:8::codeready_builder, p-cpe:/a:oracle:linux:xorg-x11-server-xdmx, cpe:/o:oracle:linux:8, p-cpe:/a:oracle:linux:xorg-x11-server-common, p-cpe:/a:oracle:linux:xorg-x11-server-devel, p-cpe:/a:oracle:linux:xorg-x11-server-xephyr, p-cpe:/a:oracle:linux:xorg-x11-server-source, cpe:/a:oracle:linux:8::appstream, p-cpe:/a:oracle:linux:xorg-x11-server-xorg, p-cpe:/a:oracle:linux:xorg-x11-server-xnest

Required KB Items: Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list, Host/local_checks_enabled

Exploit Ease: No known exploits are available

Patch Publication Date: 5/23/2024

Vulnerability Publication Date: 10/25/2023

Reference Information

CVE: CVE-2023-5367, CVE-2023-5380, CVE-2023-6377, CVE-2023-6478, CVE-2024-0229, CVE-2024-0408, CVE-2024-0409, CVE-2024-21885, CVE-2024-21886