Debian DSA-825-1 : loop-aes-utils - privilege escalation

high Nessus Plugin ID 19794

Synopsis

The remote Debian host is missing a security-related update.

Description

David Watson discovered a bug in mount as provided by util-linux and other packages such as loop-aes-utils that allows local users to bypass filesystem access restrictions by re-mounting it read-only.

Solution

Upgrade the loop-aes-utils package.

The old stable distribution (woody) does not contain loop-aes-utils packages.

For the stable distribution (sarge) this problem has been fixed in version 2.12p-4sarge1.

See Also

http://www.debian.org/security/2005/dsa-825

Plugin Details

Severity: High

ID: 19794

File Name: debian_DSA-825.nasl

Version: 1.18

Type: local

Agent: unix

Published: 10/5/2005

Updated: 1/4/2021

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.2

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:loop-aes-utils, cpe:/o:debian:debian_linux:3.1

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 9/29/2005

Vulnerability Publication Date: 9/12/2005

Reference Information

CVE: CVE-2005-2876

DSA: 825