Foxit PDF Editor < 13.1.2 Vulnerability

high Nessus Plugin ID 197923

Synopsis

A PDF toolkit installed on the remote Windows host is affected by a vulnerability

Description

According to its version, the Foxit PDF Editor application (previously named Foxit PhantomPDF) installed on the remote Windows host is prior to 13.1.2. It is, therefore affected by vulnerability:

- A privilege escalation vulnerability exists in the Foxit Reader 2024.2.0.25138. The vulnerability occurs due to improper certification validation of the updater executable before executing it. A low privilege user can trigger the update action which can result in unexpected elevation of privilege. (CVE-2024-29072)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Foxit PDF Editor version 13.1.2 or later

See Also

http://www.nessus.org/u?a27a3e57

Plugin Details

Severity: High

ID: 197923

File Name: foxit_pdf_editor_13_1_2.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 5/25/2024

Updated: 5/31/2024

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: High

Score: 8.1

CVSS v2

Risk Factor: Medium

Base Score: 4.4

Temporal Score: 3.3

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2024-29072

CVSS v3

Risk Factor: High

Base Score: 8.2

Temporal Score: 7.1

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:foxitsoftware:phantom, cpe:/a:foxitsoftware:phantompdf

Required KB Items: SMB/Registry/Enumerated, installed_sw/FoxitPhantomPDF

Exploit Ease: No known exploits are available

Patch Publication Date: 5/25/2024

Vulnerability Publication Date: 5/24/2024

Reference Information

CVE: CVE-2024-29072

IAVA: 2024-A-0315