Foxit PDF Reader < 2024.2.2 Vulnerability

high Nessus Plugin ID 197886


A PDF viewer installed on the remote Windows host is affected by a vulnerability


According to its version, the Foxit PDF Reader application (previously named Foxit Reader) installed on the remote Windows host is prior to 2024.2.2. It is, therefore affected by vulnerability:

- A privilege escalation vulnerability exists in the Foxit Reader 2024.2.0.25138. The vulnerability occurs due to improper certification validation of the updater executable before executing it. A low privilege user can trigger the update action which can result in unexpected elevation of privilege. (CVE-2024-29072)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Foxit PDF Reader version 2024.2.2 or later

See Also

Plugin Details

Severity: High

ID: 197886

File Name: foxit_reader_2024_2_2.nasl

Version: 1.5

Type: local

Agent: windows

Family: Windows

Published: 5/24/2024

Updated: 5/31/2024

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: High

Score: 7.3


Risk Factor: Medium

Base Score: 4.4

Temporal Score: 3.3

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2024-29072


Risk Factor: High

Base Score: 8.2

Temporal Score: 7.1

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:foxitsoftware:foxit_reader

Required KB Items: installed_sw/Foxit Reader, SMB/Registry/Enumerated

Exploit Ease: No known exploits are available

Patch Publication Date: 5/24/2024

Vulnerability Publication Date: 5/24/2024

Reference Information

CVE: CVE-2024-29072

IAVA: 2024-A-0315