RHEL 8 : gstreamer1-plugins-bad-free (RHSA-2024:3060)

high Nessus Plugin ID 197766

Synopsis

The remote Red Hat host is missing one or more security updates for gstreamer1-plugins-bad-free.

Description

The remote Redhat Enterprise Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2024:3060 advisory.

GStreamer is a streaming media framework based on graphs of filters which operate on media data. The gstreamer1-plugins-bad-free package contains a collection of plug-ins for GStreamer.

Security Fix(es):

* gstreamer-plugins-bad: Integer overflow leading to heap overwrite in MXF file handling with uncompressed video (CVE-2023-40474)

* gstreamer-plugins-bad: Integer overflow leading to heap overwrite in MXF file handling with AES3 audio (CVE-2023-40475)

* gstreamer-plugins-bad: Integer overflow in H.265 video parser leading to stack overwrite (CVE-2023-40476)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Additional Changes:

For detailed information on changes in this release, see the Red Hat Enterprise Linux 8.10 Release Notes linked from the References section.

Tenable has extracted the preceding description block directly from the Red Hat Enterprise Linux security advisory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the RHEL gstreamer1-plugins-bad-free package based on the guidance in RHSA-2024:3060.

See Also

https://access.redhat.com/security/updates/classification/#moderate

http://www.nessus.org/u?99ff6172

https://bugzilla.redhat.com/show_bug.cgi?id=2254587

https://bugzilla.redhat.com/show_bug.cgi?id=2254588

https://bugzilla.redhat.com/show_bug.cgi?id=2254589

http://www.nessus.org/u?50f9c223

https://access.redhat.com/errata/RHSA-2024:3060

Plugin Details

Severity: High

ID: 197766

File Name: redhat-RHSA-2024-3060.nasl

Version: 1.1

Type: local

Agent: unix

Published: 5/23/2024

Updated: 6/3/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-40475

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS Score Source: CVE-2023-40476

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:gstreamer1-plugins-bad-free-devel, cpe:/o:redhat:enterprise_linux:8, p-cpe:/a:redhat:enterprise_linux:gstreamer1-plugins-bad-free

Required KB Items: Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu, Host/local_checks_enabled

Exploit Ease: No known exploits are available

Patch Publication Date: 5/22/2024

Vulnerability Publication Date: 10/12/2023

Reference Information

CVE: CVE-2023-40474, CVE-2023-40475, CVE-2023-40476

CWE: 190

RHSA: 2024:3060