GLSA-200509-09 : Py2Play: Remote execution of arbitrary Python code

High Nessus Plugin ID 19741


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200509-09 (Py2Play: Remote execution of arbitrary Python code)

Arc Riley discovered that Py2Play uses Python pickles to send objects over a peer-to-peer game network, and that clients accept without restriction the objects and code sent by peers.
Impact :

A remote attacker participating in a Py2Play-powered game can send malicious Python pickles, resulting in the execution of arbitrary Python code on the targeted game client.
Workaround :

There is no known workaround at this time.


All py2play users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-python/py2play-0.1.8'

See Also

Plugin Details

Severity: High

ID: 19741

File Name: gentoo_GLSA-200509-09.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2005/09/17

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:py2play, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/09/17

Vulnerability Publication Date: 2005/09/06

Reference Information

CVE: CVE-2005-2875

OSVDB: 19431

GLSA: 200509-09