GLSA-200509-02 : Gnumeric: Heap overflow in the included PCRE library

High Nessus Plugin ID 19577

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200509-02 (Gnumeric: Heap overflow in the included PCRE library)

Gnumeric contains a private copy of libpcre which is subject to an integer overflow leading to a heap overflow (see GLSA 200508-17).
Impact :

An attacker could potentially exploit this vulnerability by tricking a user into opening a specially crafted spreadsheet, which could lead to the execution of arbitrary code with the privileges of the user running Gnumeric.
Workaround :

There is no known workaround at this time.

Solution

All Gnumeric users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/gnumeric-1.4.3-r2'

See Also

https://security.gentoo.org/glsa/200508-17

https://security.gentoo.org/glsa/200509-02

Plugin Details

Severity: High

ID: 19577

File Name: gentoo_GLSA-200509-02.nasl

Version: 1.20

Type: local

Published: 2005/09/06

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gnumeric, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2005/09/03

Reference Information

CVE: CVE-2005-2491

GLSA: 200509-02