GLSA-200508-17 : libpcre: Heap integer overflow

High Nessus Plugin ID 19537

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200508-17 (libpcre: Heap integer overflow)

libpcre fails to check certain quantifier values in regular expressions for sane values.
Impact :

An attacker could possibly exploit this vulnerability to execute arbitrary code by sending specially crafted regular expressions to applications making use of the libpcre library.
Workaround :

There is no known workaround at this time.

Solution

All libpcre users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/libpcre-6.3'

See Also

https://securitytracker.com/id/1014744

https://security.gentoo.org/glsa/200508-17

Plugin Details

Severity: High

ID: 19537

File Name: gentoo_GLSA-200508-17.nasl

Version: 1.17

Type: local

Published: 2005/08/30

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libpcre, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2005/08/25

Reference Information

CVE: CVE-2005-2491

GLSA: 200508-17