GLSA-200508-15 : Apache 2.0: Denial of Service vulnerability

Medium Nessus Plugin ID 19535

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200508-15 (Apache 2.0: Denial of Service vulnerability)

Filip Sneppe discovered that Apache improperly handles byterange requests to CGI scripts.
Impact :

A remote attacker may access vulnerable scripts in a malicious way, exhausting all RAM and swap space on the server, resulting in a Denial of Service of the Apache server.
Workaround :

There is no known workaround at this time.

Solution

All apache users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-servers/apache-2.0.54-r9'

See Also

https://bz.apache.org/bugzilla/show_bug.cgi?id=29962

https://security.gentoo.org/glsa/200508-15

Plugin Details

Severity: Medium

ID: 19535

File Name: gentoo_GLSA-200508-15.nasl

Version: 1.13

Type: local

Published: 2005/08/30

Updated: 2018/11/19

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:apache, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/08/25

Reference Information

CVE: CVE-2005-2728

GLSA: 200508-15