Debian DSA-784-1 : courier - programming error

Medium Nessus Plugin ID 19527

Synopsis

The remote Debian host is missing a security-related update.

Description

A problem has been discovered in the Courier Mail Server. DNS failures were not handled properly when looking up Sender Policy Framework (SPF) records, which could allow attackers to cause memory corruption.
The default configuration on Debian has SPF checking disabled, so most machines are not vulnerable. This is explained in the 'courier' manpage, section SENDER POLICY FRAMEWORK KEYWORDS.

Solution

Upgrade the courier-mta package.

The old stable distribution (woody) is not affected by this problem.

For the stable distribution (sarge) this problem has been fixed in version 0.47-4sarge1.

See Also

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=320290

http://www.debian.org/security/2005/dsa-784

Plugin Details

Severity: Medium

ID: 19527

File Name: debian_DSA-784.nasl

Version: 1.17

Type: local

Agent: unix

Published: 2005/08/30

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:courier, cpe:/o:debian:debian_linux:3.1

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2005/08/25

Vulnerability Publication Date: 2005/07/02

Reference Information

CVE: CVE-2005-2151

DSA: 784