Apache ActiveMQ 6.x < 6.1.2 Insecure Web API Vulnerability

high Nessus Plugin ID 194951


The remote host is running a web application that is affected by a Insecure Web API.


The version of Apache ActiveMQ running on the remote host is 6.x prior to 6.1.2. It is, therefore, affected by an insecure the API web that a attacker can use without any required authentication.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache ActiveMQ version 6.1.2 or later.

See Also


Plugin Details

Severity: High

ID: 194951

File Name: activemq_6_1_2.nasl

Version: 1.2

Type: combined

Agent: unix

Family: CGI abuses

Published: 5/3/2024

Updated: 6/6/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Medium

Score: 6.3


Risk Factor: High

Base Score: 9.4

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:C

CVSS Score Source: CVE-2024-32114


Risk Factor: High

Base Score: 8.5

Temporal Score: 7.4

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:activemq

Required KB Items: installed_sw/Apache ActiveMQ

Exploit Ease: No known exploits are available

Patch Publication Date: 5/2/2024

Vulnerability Publication Date: 5/2/2024

Reference Information

CVE: CVE-2024-32114

IAVB: 2024-B-0049