Debian dla-3801 : emacs - security update

low Nessus Plugin ID 194482

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-3801 advisory.

- In Emacs before 29.3, Gnus treats inline MIME contents as trusted. (CVE-2024-30203)

- In Emacs before 29.3, LaTeX preview is enabled by default for e-mail attachments. (CVE-2024-30204)

- In Emacs before 29.3, Org mode considers contents of remote files to be trusted. This affects Org Mode before 9.6.23. (CVE-2024-30205)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the emacs packages.

See Also

https://security-tracker.debian.org/tracker/source-package/emacs

https://security-tracker.debian.org/tracker/CVE-2024-30203

https://security-tracker.debian.org/tracker/CVE-2024-30204

https://security-tracker.debian.org/tracker/CVE-2024-30205

https://packages.debian.org/source/buster/emacs

Plugin Details

Severity: Low

ID: 194482

File Name: debian_DLA-3801.nasl

Version: 1.0

Type: local

Agent: unix

Published: 4/29/2024

Updated: 4/29/2024

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Low

Base Score: 1.7

Temporal Score: 1.3

Vector: CVSS2#AV:L/AC:L/Au:S/C:N/I:N/A:P

CVSS Score Source: CVE-2024-30205

CVSS v3

Risk Factor: Low

Base Score: 2.8

Temporal Score: 2.5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:emacs23-lucid, p-cpe:/a:debian:debian_linux:emacs25, p-cpe:/a:debian:debian_linux:emacs24-nox, p-cpe:/a:debian:debian_linux:emacs24, p-cpe:/a:debian:debian_linux:emacs25-nox, cpe:/o:debian:debian_linux:10.0, p-cpe:/a:debian:debian_linux:emacs23, p-cpe:/a:debian:debian_linux:emacs22, p-cpe:/a:debian:debian_linux:emacs25-lucid, p-cpe:/a:debian:debian_linux:emacs21, p-cpe:/a:debian:debian_linux:emacs21-nox, p-cpe:/a:debian:debian_linux:emacs-el, p-cpe:/a:debian:debian_linux:emacs-gtk, p-cpe:/a:debian:debian_linux:emacs-common, p-cpe:/a:debian:debian_linux:emacs-bin-common, p-cpe:/a:debian:debian_linux:emacs24-lucid, p-cpe:/a:debian:debian_linux:emacs23-nox, p-cpe:/a:debian:debian_linux:emacs-nox, p-cpe:/a:debian:debian_linux:emacs22-nox, p-cpe:/a:debian:debian_linux:emacs, p-cpe:/a:debian:debian_linux:emacs-lucid, p-cpe:/a:debian:debian_linux:emacs22-gtk

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 4/29/2024

Vulnerability Publication Date: 3/25/2024

Reference Information

CVE: CVE-2024-30203, CVE-2024-30204, CVE-2024-30205

IAVA: 2024-A-0247